API

Installare e configurare FormaLms e DoceboCE (siete pregati di scrivere le vostre domande dopo aver letto il manuale)
User avatar
max
FormaLms Guru
Posts: 1587
Joined: Thu Mar 01, 2012 10:41 am

Re: API

Postby max » Fri Jun 23, 2017 5:08 pm

Ciao, benvenuto a bordo!

In questo stesso thread, a pagina 1, c'è la documentazione delle API.
Se capisco bene ti serve registrare un utente su un sito terzo e poi passare la creazione dell'utente a Forma, ed eventualmente fare la stessa cosa con le iscrizioni a un corso?

Nella documentazione ci sono entrambe le cose
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

User avatar
alberto
FormaLms Guru
Posts: 769
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: API

Postby alberto » Sat Jun 24, 2017 12:45 pm

Hai provato a seguire la procedura indicata da NewWay?
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

User avatar
alberto
FormaLms Guru
Posts: 769
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: API

Postby alberto » Wed Jun 28, 2017 6:18 am

d.ravasco wrote:Buongiorno, volevo sapere se vi erano novità in merito alla segnalazione.
Grazie


Ciao Davide, il problema è risolto con la nuova release 1.4.3

@prime: prova a vedere i post precedenti in questa discussione, poi se hai acncora difficoltà apri per favore un nuovo thread
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

d.ravasco
Newbie
Posts: 23
Joined: Tue Apr 18, 2017 3:56 pm
Version: forma.lms 1.4.2

Re: API

Postby d.ravasco » Wed Jun 28, 2017 7:10 am

Grazie, procederò con l'aggiornamento.

d.ravasco
Newbie
Posts: 23
Joined: Tue Apr 18, 2017 3:56 pm
Version: forma.lms 1.4.2

Re: API

Postby d.ravasco » Thu Jul 20, 2017 3:53 pm

Sono riuscito a fare qualche prova ed ora se disabilito dal pannello della piattaforma l'uso delle api, il file php non mi restituisce alcun valore.
Se invece abilito la gestione delle api, posso inserire qualsiasi valore nei campi secret e key ma quello che fa fede è solamente la correttezza dell'utenza senza tener conto neanche della tipologia ossia posso usare una utenza standard da discente e con quella richiamare le api ed agire sul database.

User avatar
alberto
FormaLms Guru
Posts: 769
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: API

Postby alberto » Mon Jul 24, 2017 2:47 pm

Che versione stai usando? Sulla 1.4.3 il problema dovrebbe essere stato risolto
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

d.ravasco
Newbie
Posts: 23
Joined: Tue Apr 18, 2017 3:56 pm
Version: forma.lms 1.4.2

Re: API

Postby d.ravasco » Mon Jul 24, 2017 2:50 pm

La 1.4.3.
Con la versione precedente mi faceva eseguire le chiamate api anche se disattivate dal portale. Ora invece se le disattivo non le esegue però se le attivo non tiene conto del campo secret.

d.ravasco
Newbie
Posts: 23
Joined: Tue Apr 18, 2017 3:56 pm
Version: forma.lms 1.4.2

Re: API

Postby d.ravasco » Sat Nov 04, 2017 11:03 am

Ci sono novità in merito al fatto che le api mi permettono di eseguire operazioni anche se il valore secret e key non corrispondono a quelle riportate sul portale. Ho visto che se disabilito la creazione di un token ad ogni nuova connessione, la procedura riportata in questo post giustamente segnala che la gestione dei token è disabilitata. Nel caso come posso usare le api con questa nuova configurazione?
Grazie

User avatar
alberto
FormaLms Guru
Posts: 769
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: API

Postby alberto » Sat Nov 04, 2017 6:15 pm

Si, il problema è stato risolto sulla 1.4.3

sposto la discussione nel forum di configurazione
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

User avatar
alberto
FormaLms Guru
Posts: 769
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: API

Postby alberto » Thu Nov 16, 2017 7:06 am

d.ravasco wrote:La 1.4.3.
Con la versione precedente mi faceva eseguire le chiamate api anche se disattivate dal portale. Ora invece se le disattivo non le esegue però se le attivo non tiene conto del campo secret.


Scusa nella risposta precedente non avevo visto questo messaggio in cui dicevi di essere già sulla 1.4.3
Ricevi qualche errore quando ti connetti?
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net


Return to “Installazione e Configurazione”

Who is online

Users browsing this forum: No registered users and 0 guests