Page 1 of 1

Renderizzazione logo

Posted: Mon Jun 03, 2019 4:18 pm
by giorgino.greg
Salve a tutti.

Avrei bisogno di far corrispondere ad ogni organigramma un template.
Così ho ben pensato di andare nella cartella /templates e creare tanti template quanto necessari, dove essi contengono le varie immagini, script ecc.
In seguito, mi sono recato nella sezione di gestione degli utenti sul backend, creato degli utenti, creato degli organigrammi, e assegnato un template all'org, in seguito assegnato un utente all'org.

Cosicchè, dopo il login con l'utente alla quale avevo assegnato il template modificato, mi aspettavo che il logo (mi sono focalizzato su questo), situato in {cartella del template}/images/company_logo.png, cambiasse, ma in realtà non ha funzionato. Vedendo il link dallo strumento di analisi per sviluppatori, mi riporta sempre al logo del template standard.

La questione che mi pongo è: come posso arrivare a capire da dove viene renderizzato il logo, e in base a quale percorso viene scelto da dove deve essere presa l'immagine?
Può essere soddisfatta la mia richiesta in qualche modo? (a ogni organigramma corrisponde un template)

Grazie a tutti coloro che dedicheranno un pò di tempo per questo problema che potrebbe rispecchiare più persone!

Note: versione forma.lms 2.1
Ho provato a svuotare la cache.

Re: Renderizzazione logo

Posted: Mon Jun 03, 2019 6:11 pm
by alfa24
Prova a pulire la cache di twig.

Re: Renderizzazione logo

Posted: Thu Jun 20, 2019 3:38 pm
by mauro.renga
giorgino.greg wrote:
Mon Jun 03, 2019 4:18 pm
Salve a tutti.

Avrei bisogno di far corrispondere ad ogni organigramma un template.
Così ho ben pensato di andare nella cartella /templates e creare tanti template quanto necessari, dove essi contengono le varie immagini, script ecc.
In seguito, mi sono recato nella sezione di gestione degli utenti sul backend, creato degli utenti, creato degli organigrammi, e assegnato un template all'org, in seguito assegnato un utente all'org.

Cosicchè, dopo il login con l'utente alla quale avevo assegnato il template modificato, mi aspettavo che il logo (mi sono focalizzato su questo), situato in {cartella del template}/images/company_logo.png, cambiasse, ma in realtà non ha funzionato. Vedendo il link dallo strumento di analisi per sviluppatori, mi riporta sempre al logo del template standard.

La questione che mi pongo è: come posso arrivare a capire da dove viene renderizzato il logo, e in base a quale percorso viene scelto da dove deve essere presa l'immagine?
Può essere soddisfatta la mia richiesta in qualche modo? (a ogni organigramma corrisponde un template)

Grazie a tutti coloro che dedicheranno un pò di tempo per questo problema che potrebbe rispecchiare più persone!

Note: versione forma.lms 2.1
Ho provato a svuotare la cache.

Hai poi risolto?

Da ciò che hai descritto manca un passaggio: devi associare ogni template a un dominio.

Ti allego un articolo pubblicato sul Blog di Forma: https://elearnit.wordpress.com/2014/11/ ... itemplate/

Facci sapere :D