Problema FormaLms con Internet Explorer

Segnalate qui eventuali problemi riscontrati durante il normale utilizzo
Stefano
Newbie
Posts: 12
Joined: Tue Jul 12, 2016 4:59 pm

Problema FormaLms con Internet Explorer

Post by Stefano » Fri Feb 10, 2017 3:50 pm

Buonasera a tutti,
Ho creato un corso con articulate 360, l'ho pubblicato in versione HTML5 (ho questa necessità) e l'ho caricato su una piattaforma FormaLMS.
Il corso funziona correttamente con Chrome e con Firefox, mentre con Internet Explorer 11 non viene visualizzato niente, nemmeno il player.
Confido nell'aiuto di qualcuno, sono vermente in difficoltà. Il corso è pronto da consegnare ma mi sono accorto di questo grosso problema.

Grazie a tutti in anticipo

User avatar
max
FormaLms Guru
Posts: 1820
Joined: Thu Mar 01, 2012 10:41 am

Re: Problema FormaLms con Internet Explorer

Post by max » Fri Feb 10, 2017 4:41 pm

Buonasera,
sì, ne siamo al corrente. Difatti nella nuova versione Forma 2 abbiamo già fixato questa cosa.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

Stefano
Newbie
Posts: 12
Joined: Tue Jul 12, 2016 4:59 pm

Re: Problema FormaLms con Internet Explorer

Post by Stefano » Fri Feb 10, 2017 4:48 pm

Buonasera Massimiliano,
ti ringrazio tantissimo per la risposta, ma avevo già provveduto ad effettuare queste modifiche.
Avevo modificato il file come quello che mi hai inviato (modificando al suo interno "content"), ma non funziona comunque.
Non so più cosa fare

User avatar
max
FormaLms Guru
Posts: 1820
Joined: Thu Mar 01, 2012 10:41 am

Re: Problema FormaLms con Internet Explorer

Post by max » Fri Feb 10, 2017 5:20 pm

Vediamo se qualche collega ha una soluzione + aggiornata.
Potresti forse pubblicare come Flash con Html5 fallback?
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

Stefano
Newbie
Posts: 12
Joined: Tue Jul 12, 2016 4:59 pm

Re: Problema FormaLms con Internet Explorer

Post by Stefano » Fri Feb 10, 2017 5:24 pm

Mi dispiace ma ho necessità di pubblicare solo in HTML5 a causa di alcuni script che erano necessari per il corso.
C'è qualcos'altro che ti viene in mente?
Sono in grande difficoltà

Stefano
Newbie
Posts: 12
Joined: Tue Jul 12, 2016 4:59 pm

Re: Problema FormaLms con Internet Explorer

Post by Stefano » Mon Feb 13, 2017 9:39 am

Continuo a fare tentativi ma senza risultati

Stefano
Newbie
Posts: 12
Joined: Tue Jul 12, 2016 4:59 pm

Re: Problema FormaLms con Internet Explorer

Post by Stefano » Wed Feb 15, 2017 9:45 am

Buongiorno a tutti,
credete che ci sia una soluzione al mio problema?

luca
FormaLms User
Posts: 52
Joined: Wed Jul 25, 2012 9:38 am
Version: Docebo CE 4.0.5

Re: Problema FormaLms con Internet Explorer

Post by luca » Thu Feb 16, 2017 10:10 am

Stefano wrote:Buongiorno a tutti,
credete che ci sia una soluzione al mio problema?
Una domanda: con Explorer 11 non funziona proprio? Hai provato ad aprire la console javascript per vedere che errori ti dà? Ho avuto un problema simile, che ho scoperto in seguito dipendere dalle funzioni di debug inserite nel player javascript.

Facci sapere

Stefano
Newbie
Posts: 12
Joined: Tue Jul 12, 2016 4:59 pm

Re: Problema FormaLms con Internet Explorer

Post by Stefano » Thu Feb 16, 2017 11:40 am

Allego gli errori che si presentano. Per quanto riguarda le funzioni di debug inserite nel player javascript in che modo le hai modificate?
Attachments
Documento1.docx
(84.64 KiB) Downloaded 7 times

luca
FormaLms User
Posts: 52
Joined: Wed Jul 25, 2012 9:38 am
Version: Docebo CE 4.0.5

Re: Problema FormaLms con Internet Explorer

Post by luca » Thu Feb 16, 2017 12:02 pm

Stefano wrote:Allego gli errori che si presentano. Per quanto riguarda le funzioni di debug inserite nel player javascript in che modo le hai modificate?
Il mio errore dipendeva dai "console.log": ho scoperto che Internet Explorer non istanzia di default l'oggetto "console" se non si aprono gli strumenti di sviluppo, quindi in condizioni normali d'uso il codice arrivava al "console.log" e si bloccava. Tolti quelli, il codice funziona perfettamente.

Il tuo errore invece dipende probabilmente dalla modalità: prova a forzare il player scorm a lavorare in modalità compatibile, inserendo una riga tipo

Code: Select all

<meta http-equiv="X-UA-Compatible" content="IE=9">
o

Code: Select all

<meta http-equiv="X-UA-Compatible" content="IE=10">
nell'header dei template di formalms.

Post Reply