Paginazione messaggi inviati non funzionante

Segnalate qui eventuali problemi riscontrati durante il normale utilizzo
Post Reply
frarina
Newbie
Posts: 6
Joined: Thu Sep 18, 2014 8:38 am
Version: forma.lms 1.2
Location: Roma

Paginazione messaggi inviati non funzionante

Post by frarina » Fri Sep 19, 2014 10:19 am

Salve a tutti. ;)
Sono Passato da docebo 4.0.4 a formalms.
Sto riscontrando un problema con la paginazione dei messaggi. In pratica se vado su "Messaggi" e poi su inviati funziona sola la prima pagina mentre se provo a clccare su un altro numero di pagina non mi visualizza nessun risultato.
Mentre la paginazione dei messaggi ricevuti funziona perfettamente.
Allego Screnshot

Grazie Mille
Buona Giornata
Attachments
inviati pagina 2.jpg
Ecco uno screen del problema
inviati pagina 2.jpg (54.12 KiB) Viewed 383 times

User avatar
alberto
FormaLms Guru
Posts: 859
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Paginazione messaggi inviati non funzionante

Post by alberto » Mon Sep 22, 2014 12:53 am

Grazie per la segnalazione, apro un bug e vedo se riusciamo a darci un'occhiata.
Ma su docebo 404 funzionava?
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

frarina
Newbie
Posts: 6
Joined: Thu Sep 18, 2014 8:38 am
Version: forma.lms 1.2
Location: Roma

[Forse risolto]Re: Paginazione messaggi inviati non funziona

Post by frarina » Mon Sep 22, 2014 8:20 am

Ho verificato ed hai ragione. ;)
NON funzionava nemmeno sulla vecchia piattaforma (Docebo 404)
Quindi evidentemente e' un bug che c'e' da tempo e non dipendente dal passaggio a formalms.

Grazie
Buona Giornata

EDIT Ho risolto(anche se in maniera poco elegante) in questo modo:
Dentro "appCore/lib/lib.message.php" ho aggiunto questa riga

Code: Select all

	$ini=25*((int)array_shift($_REQUEST['ini'])-1);
dentro la funzione "outbox" subito sotto alla riga dove c'e' scritto "$ini = $tb->getSelectedElement();" che in pratica restituiva un valore sbagliato e quindi la LIMIT della query ovviamente non funzionava

arca
Newbie
Posts: 19
Joined: Fri Jan 17, 2014 12:09 pm

Re: Paginazione messaggi inviati non funzionante

Post by arca » Fri Sep 26, 2014 9:25 am

Salve,
io ho risolto il problema in modo semplice ed immediato. Se mi dite dove posso postare la soluzione la metto a disposizione.

User avatar
max
FormaLms Guru
Posts: 1820
Joined: Thu Mar 01, 2012 10:41 am

Re: Paginazione messaggi inviati non funzionante

Post by max » Fri Sep 26, 2014 10:06 am

Ciao
Ottimo, grazie!
Beh, puoi postarla direttamente qui, no?
O incolli il codice o carichi il file o i file che hai modificato
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

User avatar
alberto
FormaLms Guru
Posts: 859
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Paginazione messaggi inviati non funzionante

Post by alberto » Thu Nov 06, 2014 4:05 pm

Ciao, bug fixato per la versione 1.3 :)
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

MaxTer
Newbie
Posts: 3
Joined: Mon Nov 19, 2018 6:53 am
Version: forma.lms 1.2

Re: Paginazione messaggi inviati non funzionante

Post by MaxTer » Mon Nov 19, 2018 6:58 am

Ciao Alberto,
scusami se riapro questa vecchia discussione, ho bisogno di risolvere questo bug senza fare l'upgrade a causa di una personalizzazione pesante.
Nel changelog della versione 1.3 vedo che il riferimento al bug è:
3487 | Bug | Pagination not working in sent messages
sei in grado di dirmi su quale file siete intervenuti, che provo a fare la modifica sulla versione che ho io?
Quanto prima faremo un salto all'ultima versione cambiando tutto, ma ho bisogno che la copia con i dati vecchi funzioni anche per i messaggi inviati, grazie.

MaxTer
Newbie
Posts: 3
Joined: Mon Nov 19, 2018 6:53 am
Version: forma.lms 1.2

Re: Paginazione messaggi inviati non funzionante

Post by MaxTer » Thu Nov 22, 2018 9:36 am

Ok, ho risolto da solo, grazie lo stesso

Post Reply