Problema in test/feedback management

Segnalate qui eventuali problemi riscontrati durante il normale utilizzo
User avatar
kingbluz
FormaLms Expert
Posts: 120
Joined: Sat Dec 08, 2012 5:08 pm
Version: forma.lms 1.4.2
Location: Milano, Italy

Problema in test/feedback management

Postby kingbluz » Thu Sep 14, 2017 2:11 pm

ciao a tutti,

sto sperimentando un problema simile a quello affrontato tempo fa in un'altra discussione (http://www.elearningcommunity.net/forum/viewtopic.php?f=12&t=12576).
Il problema riguarda la corretta visualizzazione dei feedback al termine di un test.

In pratica se in un test (per esempio con 10 domande) imposto:
- il calcolo del punteggio in percentuale con soglia a 75
- inserisco due messaggi di feedback: 0-73 "Male" e 74-100 "Bene"

Quando faccio il test, se ottengo un punteggio inferiore a 73 mi compare un solo feedback ("Male", quindi correttamente), mentre se ottengo un punteggio più alto, per esempio 90, mi compaiono entrambi i messaggi (insieme: sulla prima riga "Male", sulla seconda "Bene") :shock:

Anche qui ho fatto un po' di prove e ho capito che il problema nasce dalla scelta del punteggio in percentuale: quando infatti si sceglie punteggio in punti i feedback vengono assegnati correttamente...

Quindi si tratta di un problema facilmente aggirabile impostando il punteggio di ogni singolo quiz. Infatti se ho importato per esempio 100 quiz in un test e voglio che ne vengano scelti 10 in maniera casuale, posso impostare il punteggio massimo totale a 1.000 e assegnare 10 punti a ogni domanda: in questo modo il risultato del test al massimo potrà essere 100 e i feedback funzionano correttamente.

Ma come ho scritto in un altro post di poco fa ( http://www.elearningcommunity.net/forum/viewtopic.php?f=5&t=12849 ) questa strada non è sempre percorribile, perchè se i quiz sono tanti non si riesca a impostare il punteggio dei singoli quiz...

Anche in questo caso non so come posso risolvere...

Maurizio

jasmines
FormaLms Master
Posts: 277
Joined: Fri May 03, 2013 12:29 pm

Re: Problema in test/feedback management

Postby jasmines » Thu Sep 14, 2017 3:32 pm

Sicuramente è un bug.

User avatar
anellic
FormaLms Guru
Posts: 351
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 1.4.2
Contact:

Re: Problema in test/feedback management

Postby anellic » Fri Sep 15, 2017 11:12 am

non riesco a riprodurre il comportamento che hai nè con la 1.4.1 nè con la 1.4.2
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

User avatar
kingbluz
FormaLms Expert
Posts: 120
Joined: Sat Dec 08, 2012 5:08 pm
Version: forma.lms 1.4.2
Location: Milano, Italy

Re: Problema in test/feedback management

Postby kingbluz » Fri Sep 15, 2017 12:48 pm

ciao Claudio,
secondo me il problema nasce solo quando c'è una combinazione di fattori:
- il calcolo del punteggio in percentuale
- tanti test (p.e. 100)
- scelta casuale di X test (per esempio 10)
- forse anche quiz importati tramite GIFT (dico questo perchè ho natato che in questo caso Forma assegna di default 1 punto a quiz, mentre quando li crei nell'oggetto didattico di default il valore è 0)

Ho provato anche su un'altra piattaforma 1.4.2 e il problema viene fuori...

Maurizio

15-09-2017 13-45-37.png


15-09-2017 13-47-32.png
You do not have the required permissions to view the files attached to this post.

User avatar
kingbluz
FormaLms Expert
Posts: 120
Joined: Sat Dec 08, 2012 5:08 pm
Version: forma.lms 1.4.2
Location: Milano, Italy

Re: Problema in test/feedback management

Postby kingbluz » Thu Sep 28, 2017 8:38 pm

Ciao Claudio,

per caso siete riusciti a riprodurre il problema?

Maurizio


Return to “Bug ed Errori”

Who is online

Users browsing this forum: No registered users and 1 guest