installare formalms 1.4.3 su debian 9.3

Installare e configurare FormaLms e DoceboCE (siete pregati di scrivere le vostre domande dopo aver letto il manuale)
ludan
Newbie
Posts: 23
Joined: Tue Mar 13, 2018 12:58 pm

Re: installare formalms 1.4.3 su debian 9.3

Post by ludan » Sat Mar 17, 2018 7:48 pm

dopo aver fatto tutte le prove del caso effettivamente sono giunto alla conclusione che debian 9.3 e php 5.6 siano la combinazione che genera l'errore del loop sulla fase 6 del setup in sede di caricamento delle lingue.

ho provato a passare alla deb 7.11+php 5.4 come suggerito da Claudio ed effettivamente il setup in fase 6 si è completato passando alla fase 7 di riepilogo, dove però sotto la dicitura "installation has been completed" è comparsa una scritta rossa _CONFIG_FILE_NOT_SAVED e mi viene reso disponibile il download del file config.php.

Ciò detto cliccando sul link "localhost/formalms" su cui dovrebbe esserci il logon di accesso, riparte viceversa la procedura di setup.

Aggiungo che da una verifica le tabelle del db sono tutte create correttamente

Dove ho sbagliato?
Grazie per l'attenzione e la collaborazione
L.

User avatar
canelli
FormaLms Guru
Posts: 457
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: installare formalms 1.4.3 su debian 9.3

Post by canelli » Sat Mar 17, 2018 8:19 pm

Nessuno sbaglio.
Hai un file config.php non scrivibile da apache. L'installazione ti propone il download del config già configurato. Devi caricarlo nella root dell'installazione di forma.
Claudio
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

ludan
Newbie
Posts: 23
Joined: Tue Mar 13, 2018 12:58 pm

Re: installare formalms 1.4.3 su debian 9.3

Post by ludan » Sat Mar 17, 2018 10:37 pm

Grazie infinite Claudio

ludan
Newbie
Posts: 23
Joined: Tue Mar 13, 2018 12:58 pm

Re: installare formalms 1.4.3 su debian 9.3

Post by ludan » Sun Mar 18, 2018 7:57 pm

problema risolto, assegnando i privilegi di scrittura all'utente www-data nella dir forma.
setup ok con deb 7.1 + php 5.4; confermo tuttavia problemi di compatibilità di php 5.6 su deb 9.3 con i quali non completo mai il setup.

avete indicazioni se con Forma 2.0 i problemi di compatibilità sono risolti e si possono usare distribuzioni aggiornate e versioni di php ultime (es. deb 9.3/4 + php 7.2)?

grazie infinite

L.

ludan
Newbie
Posts: 23
Joined: Tue Mar 13, 2018 12:58 pm

Re: installare formalms 1.4.3 su debian 9.3

Post by ludan » Mon Mar 19, 2018 2:11 pm

Ciao a tutti,
avete indicazioni se con Forma 2.0 i problemi di compatibilità sono risolti e si possono usare distribuzioni aggiornate e versioni di php ultime (es. deb 9.3/4 + php 7.2)?

grazie infinite

L.

User avatar
canelli
FormaLms Guru
Posts: 457
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: installare formalms 1.4.3 su debian 9.3

Post by canelli » Mon Mar 19, 2018 3:11 pm

Forma 2.0 sarà compatibile con PHP da 5.4 a 7.0
.
Stiamo risolvendo incompatibilità con 7.1 ma non è sicuro che saranno risolti per l'uscita (imminente) della 2.0

Non c'è bisogno di portare le domande a ripetizione !!!
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

Post Reply