Errore nello step 6 dell'installazione

Installare e configurare FormaLms e DoceboCE (siete pregati di scrivere le vostre domande dopo aver letto il manuale)
Post Reply
Send
Newbie
Posts: 4
Joined: Tue Sep 04, 2018 11:17 am
Version: forma.lms 2.0

Errore nello step 6 dell'installazione

Post by Send » Tue Sep 04, 2018 11:26 am

Buongiorno
sto avendo problemi con l'istallazione di forma 2.0
nella prima schermata risulta tutto regolare:

Code: Select all

Step 2: Verifica informazioni di sistema
Informazioni sul server
Server software: nginx/1.14.0
PHP Version: 7.0.30
Versione Client Mysql: : 5.0.12
Supporto Multibyte: ON
Supporto mime_content_type(): ON
Supporto Fileinfo: ON
Ldap: OFF Considerare questa nota solo se si intende usare LDAP
Openssl : : ON
Timezone Installazione: UTC
PHP Info
magic_quotes_gpc: OFF
Safe mode: OFF
register_global: OFF
allow_url_fopen : : ON
allow_url_include : : OFF
upload_max_filsize: 62M
post_max_size: 62M
max_execution_time: 60s
ma nella schermata 6 ricevo un errore generico di PHP, controllando i log del server ricevo

Code: Select all

2018/09/04 12:06:37 [error] 4988#4988: *128 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Class 'Log' not found in /*****/public/******/wwroot/db/drivers/docebodb.mysqli.php:65
Stack trace:
#0 /*****/public/******/wwroot/db/lib.docebodb.php(552): mysqli_DbConn->select_db('********')
#1 /******/public/******/wwroot/install/import_db.php(16): sql_select_db('********')
#2 {main}
  thrown in /*****/public/*****/wwroot/db/drivers/docebodb.mysqli.php on line 65" while reading response header from upstream, client: **.**.**.***, server: urzica.it, request: "GET /install/import_db.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9006", host: "****.it", referrer: "http://*****/install/index.php"
i permessi sono correttamente assegnati l'unica cosa che mi fa venire dei dubbi è che il db gira su MariaDB. :|

User avatar
canelli
FormaLms Guru
Posts: 457
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Errore nello step 6 dell'installazione

Post by canelli » Tue Sep 04, 2018 12:30 pm

unica cosa che mi fa venire dei dubbi è che il db gira su MariaDB
Mariadb va benissimo ed è utilizzabile senzanessun problema

l'errore PHP segnalato è relativo al fatto che non riesce a trovare la classe Log

Code: Select all

Uncaught Error: Class 'Log' not found in ....
Lo step 6, import del database, sta cercando di segnalare che non riesce a connettersi al database una volta connesso al server .

Controlla che utente e password di accesso al database siano corretti e che l'utente possa utilizzare il db indicato

Eventualmente crea prima , con un tools di amministrazione di mysql , il database
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

Send
Newbie
Posts: 4
Joined: Tue Sep 04, 2018 11:17 am
Version: forma.lms 2.0

Re: Errore nello step 6 dell'installazione

Post by Send » Tue Sep 04, 2018 9:33 pm

Ho trovato il problema, in pratica era dovuto ad un errore di autenticazione al db che usavo ed alla codifica dello stesso. Se entravo in phpmyadmin con l'utente di forma mi mostrava la codifica del db in utf8, ma entrando con root in latin1_swedish_ci.

Però penso di aver beccato un bug nello script d'installazione nello step 6, ma lo posto nella sezione adatta.

Post Reply