problemi installazione versione 1.4.3

Installare e configurare FormaLms e DoceboCE (siete pregati di scrivere le vostre domande dopo aver letto il manuale)
Post Reply
adino
Newbie
Posts: 2
Joined: Fri Apr 06, 2018 7:16 pm

problemi installazione versione 1.4.3

Post by adino » Fri Apr 06, 2018 7:22 pm

Salve,
ho installato in locale su macOs utilizzando MAMP, la versione di forma.lms 1.4.3....
in locale entro nella cartella install, si apre la prima schermata, step 1, dove posso scegliere la lingua, seleziono la lingua e clicco il passaggio successivo, step 2, sulla verifica informazioni di sistema e resta bloccato così.....non mi fa progredire....
Dove ho sbagliato? Come posso risolvere il problema?
Grazie a tutti.
Saluti

User avatar
canelli
FormaLms Guru
Posts: 451
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: problemi installazione versione 1.4.3

Post by canelli » Fri Apr 06, 2018 8:19 pm

Ciao adino
Probabilmente il tuo MANP utilizza una versione di PHP non supportata da forma 1.4.3 . Devi utilizzare PHP 5.6 (o meglio PHP 5.4 )
Ci sono altri thread sullo stesso argomento che ti potrebbero aiutare

Claudio
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

adino
Newbie
Posts: 2
Joined: Fri Apr 06, 2018 7:16 pm

Re: problemi installazione versione 1.4.3

Post by adino » Fri Apr 06, 2018 10:54 pm

Grazie. era sbagliata, non supportata, la versione di PHP.
Grazie tanto

harryjon
Newbie
Posts: 1
Joined: Wed May 02, 2018 10:08 am
Version: Docebo CE 3.6
Contact:

Re: problemi installazione versione 1.4.3

Post by harryjon » Wed May 02, 2018 10:13 am

I have installed npm, and also yarn (just in case npm didn't work), and upon installing and opening hyper, I was given the message that there is an error in updating plugins. I entered the plugin 'hyperline' to test into the config file. The popup window said that it cannot find 'C:\Users\JupiterStorm\.hyper_plugins\node_modules\hyperline'.

In the config file, I also modified the shell, and shell-arg:

shell: 'C:\\Program Files\\Git\\git-cmd.exe',

shellArgs: ['--command=usr/bin/bash.exe', '-l', '-i'],

User avatar
canelli
FormaLms Guru
Posts: 451
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: problemi installazione versione 1.4.3

Post by canelli » Wed May 02, 2018 2:13 pm

forma.lms is a PHP web application , not related to npm or yarnis
yuor trobule are not related with forma.lms

and please open new therd for new questions .
Claudio
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

royjon
Newbie
Posts: 1
Joined: Sat Jun 02, 2018 12:02 pm
Version: Docebo CE 4.0.4
Contact:

Re: problemi installazione versione 1.4.3

Post by royjon » Sat Jun 02, 2018 12:05 pm

Whilst using version 1.4.2 I noticed a bug when adding lists. I upgraded to 1.4.3 thinking this would fix the issue, but now get the following error:

Error: [textAngular:textAngularSetup] The textAngular-sanitize provider has been replaced by another -- have you included angular-sanitize by mistake?

I am using JSPM to install textAngular and had been using it with ng-sanitize which no longer seems to work, how can I fix this?

FYI This is what I get when I run 'jspm install textAngular', I had to add ng-sanitize separately.

"textAngular": "github:fraywing/textAngular@1.4.3",

"github:fraywing/textAngular@1.4.3": {
"angular": "github:angular/bower-angular@1.4.3",
"css": "github:systemjs/plugin-css@0.1.13",
"font-awesome": "npm:font-awesome@4.4.0",
"rangy": "github:timdown/rangy-release@1.3.0"
},
Learn how to Get Pregnant Fast :5 Actoionable ways to Boost Your Chances Of Conceiving Quickly.Complete Guide about Food,postions and Time for getting pregnant fast.

alfa24
FormaLms Expert
Posts: 165
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: problemi installazione versione 1.4.3

Post by alfa24 » Sat Jun 02, 2018 12:22 pm

Step to reproduce?
I'm Jasmines, the One

andrea.festa
FormaLms User
Posts: 59
Joined: Wed Jan 30, 2013 9:43 am

Re: problemi installazione versione 1.4.3

Post by andrea.festa » Mon Oct 08, 2018 12:26 pm

Sto installando Forma 1.4.3 su un server Linux con PHP 5.4.16

L'installazione si blocca con una schermata bianca su "Step 2"
Ho trovato il seguente errore in httpd/error_log
"PHP Fatal error: Call to undefined function mysql_get_client_info() in /var/www/html/install/controllers/Step2Controller.php on line 25, referer: http://10.4.22.44/install/index.php"

Qui - http://php.net/manual/en/function.mysql ... t-info.php - leggo che la funzione mysql_get_client_info() dovrebbe essere stata deprecata dalla versione 5.5 di PHP ed eliminata nella versione 7.0

Ho provato anche a modificare la riga 25 nel file Step2Controller.php da

preg_match( '/([0-9]+\.[\.0-9]+)/', mysql_get_client_info(), $version );

a
preg_match( '/([0-9]+\.[\.0-9]+)/', mysqli_get_client_info(), $version );

senza nessun risultato.

Cosa mi suggerite di fare?

Grazie.

User avatar
alberto
FormaLms Guru
Posts: 857
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: problemi installazione versione 1.4.3

Post by alberto » Mon Oct 08, 2018 3:45 pm

Io ti suggerisco di installare Forma 2.0 :)
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

andrea.festa
FormaLms User
Posts: 59
Joined: Wed Jan 30, 2013 9:43 am

Re: problemi installazione versione 1.4.3

Post by andrea.festa » Tue Oct 09, 2018 7:53 am

Grazie per il suggerimento, Alberto, ma ora non posso installare Forma 2.0
In futuro sicuramente.

Cosa posso fare instanto per sbloccare l'installazione della 1.4.3?

Post Reply