Page 1 of 1

Recommended environment

Posted: Sat Dec 29, 2018 12:32 pm
by maruggio
Hi

I intend to install FormaLMS 2.0 on a Linux or BSD base. What is currently a recommended and secure OS/DB constellation?

thx.

Re: Recommended environment

Posted: Wed Jan 02, 2019 11:13 am
by max
Hi Oliver,
You can check out the readme.txt file http://www.formalms.org/versions/readme.txt

Re: Recommended environment

Posted: Wed Jan 02, 2019 3:59 pm
by maruggio
Thanks for your response, max. I already verified the readme and changelog. Today it is not easy to quick install formalms 2.0 (not 2.1) with latest Linux distros on test VMs for multiple testers:
Eg. Ubuntu 18.04 has standard PHP is 7.2 or other distributions use MySQL 5.7 or there were compat probs. I also wanted to install formalms on my plesk environment on ubuntu 16.04 (still) with central DB with MySQL 5.7. For that DB I do not want to change MySQLs DISTINCT found in this post: viewtopic.php?f=10&t=13146&p=19982&hili ... 5.7#p19982, because of Plesk.

My fastest VM installation to meet all formalms 2.0 requirements and versions is a VM running OpenBSD 6.4 with apache2.4, php 7.0 and MariaDB.

Re: Recommended environment

Posted: Wed Jan 02, 2019 4:25 pm
by max
Thanks Oliver for your feedback. Support for Php 7.1 is coming with one of the next versions

Re: Recommended environment

Posted: Thu Jan 03, 2019 6:17 am
by alfa24
You don't have to change globally your mysql settings.
You have to rewrite some queries. They are not so many as you can think and if you rewrite them you will appreciate better performance too.
I can help if you need.

Re: Recommended environment

Posted: Fri Jan 04, 2019 3:39 pm
by maruggio
@alfa24 Many thanks. Currently it is not yet necessary becuaser I am testing the features and GUI, but I'll come back to you.

Re: Recommended environment

Posted: Thu Jan 10, 2019 7:48 pm
by canelli
maruggio wrote:
Wed Jan 02, 2019 3:59 pm
16.04 (still) with central DB with MySQL 5.7. For that DB I do not want to change MySQLs DISTINCT found in this post: viewtopic.php?f=10&t=13146&p=19982&hili ... 5.7#p19982, because of Plesk.

My fastest VM installation to meet all formalms 2.0 requirements and versions is a VM running OpenBSD 6.4 with apache2.4, php 7.0 and MariaDB.
Not all mysql 5.7 installation come with the global setting offending formalms query, so mysql 5.7 can be used without global change in many linux dstribution and / configuration. the setting can be applied also in a "per user" methiod depending on your installation. you can also use a docker ... . Mariadb 5.x or 10.x can also be a good choice.

PHP 7.1 or greater are not supported and there are know bugs in forma 2.0 . The support for php 7.1 will not be available in forma 2.2

Re: Recommended environment

Posted: Tue Jan 15, 2019 3:50 pm
by maruggio
Thanks claudio for your input concerning MySQL 5.7.