New installation of 2.0

Install and configure FormaLMS and DoceboCE
Post Reply
ejansen
Newbie
Posts: 2
Joined: Fri Jun 29, 2018 7:20 pm

New installation of 2.0

Post by ejansen » Fri Jun 29, 2018 7:37 pm

I've been evaluating a number of learning management systems and FormaLMS looks good.

I downloaded the 2.0 version and attempted to install on top of a new installation of the latest XAMPP release.
(https://sourceforge.net/projects/forma/ ... =directory)

The FormaLMS install stops at step 2 and reports that there is a permission problem with config.php.
A little investigation reveals that the problem is that there is not a config.php in the FormaLMS base
directory. There is a config.dist.php, but no config.php. The file path was determined by adding
a print statement to Step2Controller.php where the "is_writable" check is performed against
"_base_.'/'.$file_name".

I see that this version was just released, so perhaps this was just an oversight ?

Thanks,
Eric

User avatar
canelli
FormaLms Guru
Posts: 469
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: New installation of 2.0

Post by canelli » Fri Jun 29, 2018 10:30 pm

The installer can run without the config.php file. It will made new one at the end of installation. The config.php will be write onto the root folder (if writetable) or will be downloadable.

If step2 stuck without the config.php create an empty file in root folder
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

ejansen
Newbie
Posts: 2
Joined: Fri Jun 29, 2018 7:20 pm

Re: New installation of 2.0

Post by ejansen » Fri Jun 29, 2018 11:40 pm

Yes ! I had to revert from XAMPP 7.2.6 to XAMPP 7.0.30-0 and create an empty config.php.
It's up and running.
Thanks !
Eric

User avatar
canelli
FormaLms Guru
Posts: 469
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: New installation of 2.0

Post by canelli » Sat Jun 30, 2018 1:05 pm

Yeah
Php 7.2 is not yet fully supported
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

zaff
Newbie
Posts: 2
Joined: Mon Aug 06, 2018 7:05 pm
Version: forma.lms 2.0

Re: New installation of 2.0

Post by zaff » Mon Aug 06, 2018 7:11 pm

I am trying to install formalms 2.0 in PHP - 7.0.3
Ubuntu - 16.04.1. I get red highlighted in step 7 "The installer was unable to save the config.php file, download it and overwrite it online.". I have downloaded config file and uploaded in root folder using filezilla. After this my webpage does not open up. I have tried setting a blank copy of config.php file and done a fresh install. I still get the same message. I tried removing config.dist.php .. I still get the same message. I am not able to past step 7 ...worse, after step 7 when i try to open page, I get "this page isn't working "

zaff
Newbie
Posts: 2
Joined: Mon Aug 06, 2018 7:05 pm
Version: forma.lms 2.0

Re: New installation of 2.0

Post by zaff » Mon Aug 06, 2018 8:25 pm

Just as an update , I was able to pass step 7 without any red lines - Installation is complete. I gave all access to the files and config.php file (config.php file was created as a blank page). So the final message is isntallation complete. Now when i go to my browser to type of the ip address of vps. It gives me "this page isn't working" ...... any help ??

User avatar
canelli
FormaLms Guru
Posts: 469
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: New installation of 2.0

Post by canelli » Mon Aug 06, 2018 8:30 pm

See my previous post
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

Post Reply