Upgrade from 2.0rc1

Install and configure FormaLMS and DoceboCE
Post Reply
marcoach
Newbie
Posts: 7
Joined: Tue Nov 14, 2017 11:31 am

Upgrade from 2.0rc1

Post by marcoach » Thu Jun 28, 2018 2:22 pm

Hi,
At the moment we are using RC1, and we want to upgrade to 2.0.
From what i understood that's not possible, so we install a previous version and then proceed with the upgrade.
The only problem is that we already have a db with data we'd like to keep and use in the new version.
It's possible to save it and use it for the new version 2.0? So we don't have to do everything

Thanks for your support
Fabio

User avatar
canelli
FormaLms Guru
Posts: 469
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Upgrade from 2.0rc1

Post by canelli » Thu Jun 28, 2018 2:52 pm

Hi

The upgrade procedure is available only from forma 1.x or docebo CE 3.6 and 4.x to 2.x.
The upgrade is NOT avilable from forma 2.0 alpha, beta or RC1


The upgrade has been developed to be applied many times on the same database.

To reapply an upgrade from previous version to the current one, you must trick with the database data .
in the table core_setting , row with paramter_name core_version , you must update param_value with value "1.4.3"
with an database admin tools , like phpmyadmin , run following sql update

Code: Select all

UPDATE core_setting SET param_value = '1.4.3'  WHERE param_name = 'core_version'; 
we do not guarantee that the applied upgrade will always work all the time and that it works in all cases of db of intermediate beta or test versions.
made a database backup before any upgrade . try first on a test environment . !!

To extract data from a live db and insert them in a backup copy is an hard work
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

Post Reply