FORMALMS & AZURE

Install and configure FormaLMS and DoceboCE
Post Reply
jrgilo
Newbie
Posts: 6
Joined: Mon Jan 29, 2018 5:11 pm
Version: forma.lms 2.0
Location: Mexico City, Mexico

FORMALMS & AZURE

Post by jrgilo » Wed Jul 11, 2018 9:09 pm

I'm attempting to deploy formalms over an Azure environment.
Has anyone tried this successfully? I'm finding simple yet annoying issues that I'm not sure how to deal with, for example:
1. Avatar pics are not shown - Files are uploaded (I can see the files imported with no extension to the xxx/Photos directory) simply not displayed. I´ve tried several file extensions and file sizes to no avail.
2. When making changes to certain items like links or scorm courses, after saving changes the page takes over 2 mins to load if it refreshes at all. (the changes are applied, however, the page does not refresh or display a success message).
3. Scorm courses are not displayed on all browsers. Chrome is the most problematic. I know this may be related to the course I'm testing with. Does anyone have a sample file I can test with that works on Chrome, IE, Firefox, Safari?

Any pointers would be greatly appreciated!

This is my server configuration info:
Server configuration
Server address:
Server port: 80
Server name: xxxxxxxxxx.azurewebsites.net
Server admin email:
Server software: Microsoft-IIS/10.0

MySQL information
sql vers: 5.6.39.0
sql mode: ""
sql encoding: utf8
sql collation: utf8_general_ci
sql timezone: SYSTEM

Info about PHP
PHP version: 7.0.30
Site Timezone: America/Los_Angeles
"safe_mode" configuration: Off
Configuration of "register_global": Off
Configuration of "magic_quotes_gpc": Off
Configuration of "upload_max_filesize": 50M
Configuration of "post_max_size": 50M
Configuration of "max_execution_time": 300s
LDAP: Off Consider this parameter only if you need to authenticate through LDAP
Configuration of "allow_url_include": Off
PHP extension php_openssl: On
Configuration of "allow_url_fopen": On

The only settings I´ve changed for PHP are "upload_max_filesize" & "post_max_size"
Thanks everyone for any input! :oops: :D

User avatar
canelli
FormaLms Guru
Posts: 457
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: FORMALMS & AZURE

Post by canelli » Thu Jul 12, 2018 11:16 am

Hi JRGILO

as I can see from your post , you are using IIS web server on a Microsoft windows server .

in release notes the IIS web server is listed as a usable webserver, but is not the primary choiche . The development and test web server is Apache.
We have some installation of formalms on IIS version 7 and 8.x ( windows server 2012) .

Your issues can be related with IIS 10.0 , Windows server 2016 or Azure features (firewall, mimetype , ecc )
Can you install Apache 2.4 on your server and made test ?
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

jrgilo
Newbie
Posts: 6
Joined: Mon Jan 29, 2018 5:11 pm
Version: forma.lms 2.0
Location: Mexico City, Mexico

Re: FORMALMS & AZURE

Post by jrgilo » Wed Aug 01, 2018 6:02 am

I appreciate the response.
I´m unable to use Apache on Azure´s webapps services. You can build a VM and run Apache that way, but it is more expensive.
We are on a limited budget so I will attempt to change the IIS version.
Ill be sure to give you guys an update
Thanks again!

User avatar
canelli
FormaLms Guru
Posts: 457
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: FORMALMS & AZURE

Post by canelli » Wed Aug 01, 2018 9:16 am

I recently upgraded a forma.lms installation on a Windows server 2008 R2 with IIS 7.5
I upgraded php to version 7.0 and forma to 2.0
All the web runs fine. images and icons from template with extension .svg was not displayed I needed to insert the svg extension in the mime type definition of IIS .
for your problem with images, check the extension / type and check if the mime type is correctly registered in IIS . Also for scrom file components
IIS returns a 404 or 403 error for unknown (mimetype) file extension

If you need professional support on setting IIS and troubleshooting your installation send me a PM
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

jrgilo
Newbie
Posts: 6
Joined: Mon Jan 29, 2018 5:11 pm
Version: forma.lms 2.0
Location: Mexico City, Mexico

Re: FORMALMS & AZURE

Post by jrgilo » Mon Aug 27, 2018 6:43 pm

Thanks for your input. After several attempts I was able to add the mime types via web.config file and images are displayed correctly now
For the chrome issue I experienced I added a flash exception to the browser and the blank screen is now replaced by the scorm player.
It seems forma is now fully functional.
Thanks for the help!

Post Reply