Mod Coursereport

Third party modules, patches, bugfixes
User avatar
alberto
FormaLms Guru
Posts: 914
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Mod Coursereport

Post by alberto » Fri Apr 13, 2012 6:35 pm

This patch fixes the following bugs in the Coursereport module (grade book) in Docebo 405.

#Bug: in the test stats the answers for ET questions are not displayed
#Bug: in the test stats the percentages are wrongly calculated
#Bug: in the test stats for the MC questions, the "not answered" percentages were not displayed

The following files were modified:

doceboLms/modules/coursereport/ajax.coursereport.php
doceboLms/modules/coursereport/ajax.coursereport.js

Please read the installation instruction in the readme file

NOTE: this patch is already included in Forma 1.0
Attachments
mod_coursereport.zip
mod coursereport - patch files
(41.47 KiB) Downloaded 76 times
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

ebsi
FormaLms User
Posts: 28
Joined: Mon Jun 25, 2012 3:50 pm
Location: Mayo, Ireland
Contact:

Re: Mod Coursereport

Post by ebsi » Mon Jun 25, 2012 3:55 pm

Thanks Alberto ist much appreciated!

Thomas

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: Mod Coursereport

Post by docebogal » Thu Jun 20, 2013 8:53 am

Alberto,
I have installed the above patch - thank you.
Even after patch is installed, it appears in the test stats, the answers for AS-Association questions will not display.
Is this a related problem?
Do you have a fix?
Thanks for your help.

User avatar
alberto
FormaLms Guru
Posts: 914
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Mod Coursereport

Post by alberto » Mon Jun 24, 2013 6:56 am

Hi Docebogal, the stats seem to work properly: for the AS questions the stats shows the % of correct associations to each fixed choice. Maybe you need a different behaviour?
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: Mod Coursereport

Post by docebogal » Mon Jun 24, 2013 7:07 am

Thank you for your reply Alberto,
Is there a way you could show me a screen grab of what you are looking at to make sure we are on the same page?
When I go to Stat area/Learning Object Stats, click on a test that has an AS-Association question, then click on a user, I cannot see the question answer associations (A-B, B-A) that were shown when I took the test, does that make sense?

Also, If you can tell me how to upload images, I can show you what I mean.

User avatar
alberto
FormaLms Guru
Posts: 914
Joined: Fri Mar 02, 2012 9:18 am
Contact:

Re: Mod Coursereport

Post by alberto » Mon Jun 24, 2013 8:33 am

It's not in the learning object stats but in teacher area/grade book: in the table header for each test you have a small istogram icon, click it to see the answer pecentages for each question.
--------------------------------------------------
Become a CONTRIBUTOR

Support the project for FREE!
www.Elearnit.net

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: Mod Coursereport

Post by docebogal » Mon Jun 24, 2013 8:59 am

I can see the graphic results under the istogram icon for the entire class as you suggested - thank you.
I was wanting to see those same results by individual student. Is there a way to show those same results for an individual student?
(Maybe I'm just not clicking on the right thing...)
I appreciate all of your help.

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: Mod Coursereport

Post by docebogal » Mon Jun 24, 2013 3:23 pm

Since this thread appears to be directed more at the gradebook class results, should I start a new thread to address the individual student display results in the LO Stats?
Thanks again.

docebogal
FormaLms User
Posts: 55
Joined: Thu Nov 08, 2012 11:58 pm

Re: Mod Coursereport - User stats display

Post by docebogal » Wed Jun 26, 2013 11:20 pm

AssociationQuestionscreengrab.jpg
AssociationQuestionscreengrab.jpg (474.84 KiB) Viewed 451 times
Notice in the image/attachment a screengrab composite of 2 sections:

Top section called "Title : Color Test" shows test with SC, MC, and AS questions and related answers/responses.

Bottom section called "Stats by Student/Object" shows the user stats for each question - however, the answers for the AS question (#3) do not appear directly under the question as they do for question 1 and 2, only the score.

How do I fix this problem so that the answers for question 3 display under user stats, just like they do for question 1 and 2?
thanks,

User avatar
max
FormaLms Guru
Posts: 2061
Joined: Thu Mar 01, 2012 10:41 am

Re: Mod Coursereport

Post by max » Thu Jun 27, 2013 8:00 am

Hi Docebogal,

the behaviour you've noticed is actually "normal" for AS questions. For sure, it is not optimal, but the stats for this type of questions actually behave like that.
A functional enhancement would be needed to solve the issue.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

Post Reply