Custom Menu not working as per requirements

Questions about the backend functionalities: configuration, user management, course management, ...
Post Reply
haseeb
Newbie
Posts: 24
Joined: Sun Sep 30, 2018 6:01 pm
Version: forma.lms 2.0

Custom Menu not working as per requirements

Post by haseeb » Mon Nov 05, 2018 8:04 am

I have created a course with custom menu called "Student" which has "User" as menu item and I have assigned 4 modules to it as shown in the picture. I have also set appropriate rights to module as well.
1.PNG
But when I login as an admin I only see this as shown in image.
2.PNG
And when I login as Student I only see this as shown in image.
3.PNG

haseeb
Newbie
Posts: 24
Joined: Sun Sep 30, 2018 6:01 pm
Version: forma.lms 2.0

Re: Custom Menu not working as per requirements

Post by haseeb » Mon Nov 05, 2018 8:04 am

WHy I am not seeing the appropriate module according to rights with admin and student login?

User avatar
max
FormaLms Guru
Posts: 1941
Joined: Thu Mar 01, 2012 10:41 am

Re: Custom Menu not working as per requirements

Post by max » Mon Nov 05, 2018 8:45 am

Hi,
ok, you've created a custom menu, but did you assign it to the course?

Concerning picture 2 => logging is as an admin on the LMS does not mean you are an admin in the course. If you are an admin in the course you will know before entering it (it's written on the course miniature in the "my courses" page) and you will also see other menu items in the dropdown menu.

In summary: you are seeing the menu you are using, with the permission that have been selected.

Check and correct your custom menu (every item) and assign it to the course.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

haseeb
Newbie
Posts: 24
Joined: Sun Sep 30, 2018 6:01 pm
Version: forma.lms 2.0

Re: Custom Menu not working as per requirements

Post by haseeb » Mon Nov 05, 2018 10:32 am

Yes I have assigned it to the course when I created it.

If I am login as an admin I can see an administrator in the course miniature as you can see in the picture.
1.PNG
You mentioned "admin will also see other menu items in the dropdown menu." but I can't see any other menu item except the menu assigned to the course even If I am login as an admin.
2.PNG
It seems the only menu I can see which s assigned to course even if the user is admin he doesn't have full right

Refer the picture for customer menu and its assigned module
3.png

haseeb
Newbie
Posts: 24
Joined: Sun Sep 30, 2018 6:01 pm
Version: forma.lms 2.0

Re: Custom Menu not working as per requirements

Post by haseeb » Mon Nov 05, 2018 10:38 am

This is the module which has administrator rights. But I am unable to see that menu when I login as an admin. Is there something wrong?
1.PNG

Post Reply