User Profile Avatar does not upload

Questions about the backend functionalities: configuration, user management, course management, ...
Post Reply
marius
Newbie
Posts: 20
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

User Profile Avatar does not upload

Post by marius » Thu Mar 02, 2017 10:48 am

Good day.
I'm running Forma 1.4.2 on Ubuntu, with Apache and PHP5.6.
I am unable to upload user profile Avatars from the user admin section. I do get to the relevant upload screen, then select an image and click "Save changes", but the screen only seems to refresh and does not upload any image. I've checked the relevant vsftp logs and there is no entry of an attempted file upload.

I've tested other uploads within the LMS section - learning objects seem to upload without an issue including pdf files and scorm packages.

I'd appreciate any possible advice. Thanks

User avatar
max
FormaLms Guru
Posts: 1950
Joined: Thu Mar 01, 2012 10:41 am

Re: User Profile Avatar does not upload

Post by max » Thu Mar 02, 2017 4:15 pm

Hi Marius
I checked on a Forma 1.4.2 and didn't have any issue in uploading an avatar image. I understand that you are generally able to upload files on your installation, therefore I would exclude permissions-related issues. Would you try with a different image, maybe with a .jpg file?
Or maybe your file was larger than the maximum allowed size?
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

marius
Newbie
Posts: 20
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: User Profile Avatar does not upload

Post by marius » Sun Mar 05, 2017 6:56 pm

Hi Max
I've tried with varies image types including jpg, png and gif. Also tried smaller that 150px images - all with the same result that the image is not uploaded.
I've checked all permissions, Apache user owns the entire web folder structure and the FTP user also has access to the necessary folders to upload files. I tested the FTP functionality separately through Filezilla and it works fine. As mentioned previously, I do not even see an entry into the FTP log files when attempting to upload an avatar image - so my guess is that the page does not even execute the upload...
Could you confirm the folder to where the avatar images should be uploaded?

User avatar
max
FormaLms Guru
Posts: 1950
Joined: Thu Mar 01, 2012 10:41 am

Re: User Profile Avatar does not upload

Post by max » Mon Mar 06, 2017 8:51 am

/files/appCore/photo/
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

marius
Newbie
Posts: 20
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: User Profile Avatar does not upload

Post by marius » Mon Mar 06, 2017 5:26 pm

Hi Max
Thanks for the info. Tested it again and the ftp-user definitely has write access to /files/appCore/photo/, but it does not look like the ftp upload functionality is executed by the avatar upload page.

Is there some way that I can debug the functionality? I also installed a "test" environment on my laptop running Mint (Ubuntu) and getting exactly the same behavior as on the Ubuntu server...

Regards

User avatar
max
FormaLms Guru
Posts: 1950
Joined: Thu Mar 01, 2012 10:41 am

Re: User Profile Avatar does not upload

Post by max » Mon Mar 06, 2017 5:31 pm

yes, under administration > main > configuration > settings > advanced you can turn on the debugging feature
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

marius
Newbie
Posts: 20
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: User Profile Avatar does not upload

Post by marius » Wed Mar 08, 2017 8:06 am

Thanks Max - I'll give that a try and see what comes up...

zamerini
Newbie
Posts: 1
Joined: Wed Mar 08, 2017 11:32 am
Version: forma.lms 1.4.2

Re: User Profile Avatar does not upload

Post by zamerini » Wed Mar 08, 2017 11:48 am

I've the same problem

Ubuntu 14.04.1 LTS

Apache/2.4.7
Loaded modules: core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_mime prefork mod_negotiation mod_php5 mod_setenvif mod_status

PHP Version 5.5.9-1ubuntu4.21
I checked that fileinfo support is enabled

<doc_root>/files and subdirs have 0777 permission mask

After enabling the error display, i didn't see nothing that can helps me, look the attachment.
Attachments
Schermata 2017-03-08 alle 11.36.28.png

marius
Newbie
Posts: 20
Joined: Wed Oct 05, 2016 3:59 am
Version: forma.lms 1.4.2

Re: User Profile Avatar does not upload

Post by marius » Mon Apr 10, 2017 3:09 pm

Still the same issue as listed previously. No error is displayed even in debug mode. As soon as the Save Changes button is pressed the page only refreshes and no file is uploaded + no error displayed.

Regards

Post Reply