White Screen on Scorm Object

Questions about the backend functionalities: configuration, user management, course management, ...
billtreneer
Newbie
Posts: 4
Joined: Tue Nov 24, 2015 9:37 pm

White Screen on Scorm Object

Postby billtreneer » Sat Nov 28, 2015 9:24 pm

Am new to Forma LMS. Using Forma 1.4.1 LMS with MySQL 5.6.19 and PHP 5.4.31. Created an 80 question exam with Adobe Captivate and saved it as a 1.2 Scorm file. The file size is 7.7M. Was able to change the max upload file size on Forma/PHP from 2M to 40M and the post_max_size from 8M to 42M in the php.ini file. After uploading, the exam file now shows up in the Forma LMS content library. When I play the file from the content library, all I get is a blank white screen. Any ideas how to fix this?

User avatar
max
FormaLms Guru
Posts: 1595
Joined: Thu Mar 01, 2012 10:41 am

Re: White Screen on Scorm Object

Postby max » Sun Nov 29, 2015 1:09 pm

Hi,

first of all, welcome to our community!

I tested some scorm objects from the content library, they display correctly. Tbh, none of them was created with Adobe Captivate (we normally use other tools).

Does your scorm display correctly if you play it locally?

Have you tried to play it inside a course, in the Student Area>course documents menu item (where it is supposed to be displayed, actually)?
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

billtreneer
Newbie
Posts: 4
Joined: Tue Nov 24, 2015 9:37 pm

Re: White Screen on Scorm Object

Postby billtreneer » Sat Dec 05, 2015 11:05 pm

The Scorm object came up in the Student Area. Thanks for your help. Am next going to try to get the course to publish in a web environment. Have not seen any documentation on how to do that for Forma LMS 1.4.1, only for DOCEBO. Do you have further documentation on Forma LMS? Thanks again for your help.

billtreneer
Newbie
Posts: 4
Joined: Tue Nov 24, 2015 9:37 pm

Re: White Screen on Scorm Object

Postby billtreneer » Sat Dec 05, 2015 11:08 pm

These two error messages did come up when I loaded the Scorm file to the Student area. Had to Click OK on them and the file loaded. Any help with these would be much appreciated. Thanks for your help.
You do not have the required permissions to view the files attached to this post.

User avatar
max
FormaLms Guru
Posts: 1595
Joined: Thu Mar 01, 2012 10:41 am

Re: White Screen on Scorm Object

Postby max » Wed Dec 09, 2015 2:03 pm

Hi,
from these 2 errors all I can say is that there are some miscommunications between the object and the lms.
Do you only get this error with this object or with all of them? If it's only this one, you might want to change your publishing and/or tracking options and do some testing.

I would advise to publish and upload a very short test LO with 2 questions, just to see how it behaves.

If you still have issues, you can
- send me your captivate project with a wetransfer or something like that
- tell me with what version of Captivate you published it
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

Magda
Newbie
Posts: 8
Joined: Mon May 16, 2016 1:03 pm
Version: forma.lms 1.4.1

Re: White Screen on Scorm Object

Postby Magda » Sat Jun 04, 2016 2:42 pm

Hi Max
I have the same problem that the screen will stay blank and am using Articulate Storyline 2

User avatar
max
FormaLms Guru
Posts: 1595
Joined: Thu Mar 01, 2012 10:41 am

Re: White Screen on Scorm Object

Postby max » Mon Jun 06, 2016 9:35 am

Hi,
welcome on board!

Try a little troubleshooting to understand what the issue is:

- does the course display correctly when viewed locally?
- did you upload it to Forma in a web environment or in a local installation?
(I am asking because Articulate itself says that content viewed locally might have issues)
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

Magda
Newbie
Posts: 8
Joined: Mon May 16, 2016 1:03 pm
Version: forma.lms 1.4.1

Re: White Screen on Scorm Object

Postby Magda » Mon Jun 06, 2016 3:22 pm

Hi Max
I build the package on a local version of storyline and then upload on the web version of my lms. What do you suggest I do?

Magda
Newbie
Posts: 8
Joined: Mon May 16, 2016 1:03 pm
Version: forma.lms 1.4.1

Re: White Screen on Scorm Object

Postby Magda » Mon Jun 06, 2016 3:37 pm

I have asked my db and below his response
These will have to be taken up with the developers as this is code that they use to insert information into the database, it seems that the mysql code being used is generating errors when you insert an entry into the database. the full query will need to be debugged to see what the full mysql code is. Have you checked on the online forums regarding this error ?

User avatar
max
FormaLms Guru
Posts: 1595
Joined: Thu Mar 01, 2012 10:41 am

Re: White Screen on Scorm Object

Postby max » Mon Jun 06, 2016 5:14 pm

Hi Magda,

I understand that the file was uploaded on a web LMS, alright. Still don't know if your course worked locally. Is that the case?

That said, the information you received is not very useful to help me understand what your problem is. Let's try another checklist that might be make more sense:

- as above: is your course working correctly, when viewed locally?
- have you published for LMS?
- have you uploaded it as a scorm object?
- do you have Flash Player on your PC?
At least, version 10.3 as you can see here in the SL2 System Requirements
https://www.articulate.com/support/storyline-2/system-requirements-for-articulate-storyline-2
- When do you get the blank page? Are you able to upload the scorm correctly and then you get the blank page when playing it, or is it during upload?
- do you have any error message, or just a blank page?
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it


Return to “Administration Management”

Who is online

Users browsing this forum: No registered users and 1 guest