Problem in login after installation

Please report here problems and bugs
tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Problem in login after installation

Post by tempuser » Wed Feb 28, 2018 3:50 pm

Hello,

I have recently installed the latest version 1.4.3, and when I try to login it doesn't show the system pages, just keeping to show the same login page without an error message.

I traced it on Firefox, and seemingly there is a "302 Moved Temporarily" error.

It tries to redirect to

/appLms/index.php?modname=login&op=confirm

then to

/appLms/index.php?r=lms/elearning/show


Request Trace:
Date
Wed, 28 Feb 2018 07:28:07 GMT
Server
Apache
X-Powered-By
PHP/5.4.45
Expires
Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control
no-store, no-cache, must-reval…te, post-check=0, pre-check=0
Pragma
no-cache
Location
http://.................../a…ndex.php?r=lms/elearning/show
Content-Type
text/html
Set-Cookie
docebo_session=def676df95985dba1477ad50fadb699e; path=/
Transfer-Encoding
chunked
Connection
keep-alive

Response Trace:
Host
..........................com
User-Agent
Mozilla/5.0 (Windows NT 10.0; …) Gecko/20100101 Firefox/56.0
Accept
text/html,application/xhtml+xm…plication/xml;q=0.9,*/*;q=0.8
Accept-Language
ar,en-US;q=0.7,en;q=0.3
Accept-Encoding
gzip, deflate
Referer
http://...............................com/index.php
Content-Type
application/x-www-form-urlencoded
Content-Length
171
Cookie
__unam=dd466f6-15cd4c44875-4d0…208b519b535eb892c279cfb7295c0
Connection
keep-alive
Upgrade-Insecure-Requests
1

And it both cases the same "302 Moved Temporarily" error, so it shows the login page again without an error message.

Any idea what is the reason behind this issue?

Thank you.

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Fri Mar 02, 2018 7:26 am

Please see this post on Stakeoverflow: https://stackoverflow.com/questions/241 ... emporarily

Are you redirecting to external URLs somewhere in the code? What could be the issue? Is it dependent on some Apache configuration?

User avatar
canelli
FormaLms Guru
Posts: 482
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Problem in login after installation

Post by canelli » Fri Mar 02, 2018 9:26 am

Hi

the login procedure does not redirect you to an external url . it's a nonsense .
If you try to login into formal.lms, the platform needs to retain you into the platform.
after a successful login you are redirected into the "user home page" http://yourformalmsdoamins.com/appLms/i ... rning/show

I suppose that you have some errors with the php configuration .
After login, and the redirect to the login page , are you, in any case, logged in ? if you enter the "user homepage" link in the browser can you navigate the system ? or are you redirect to the login page?

If you are not logged in, there are some problems with php session storage. Check on server the php session configurations and if php can wrte the session

Claudio
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Fri Mar 02, 2018 5:06 pm

Hello,

I'm hosting several websites that are using PHP sessions and redirections, this issue had never been faced over the span of years. Does it have anything to do with session settings in config.php?

The login is completed successfully, no login error messages are shown, and I checked the latest login timestamp in database. The issue is in redirection after login.

User avatar
canelli
FormaLms Guru
Posts: 482
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: Problem in login after installation

Post by canelli » Fri Mar 02, 2018 5:46 pm

Hello

the login procedure work correclty in any version of forma.lms
Please check your apache and PHP configuration . see in the apache log file and php error log (if defined) if there are some errors.

What version of
apache , php , mysql are you using ?
Does it have anything to do with session settings in config.php?
haver you changed the session default setttings in the config ?

Please , after login and redirection to the login page can you try the following link ?
http://yourdomain.tld/pathtoformalms/in ... rning/show
(Change yourdoamin.tld and pathtoforma wiith correct value for your installation)
What happen ?
If you are redirected to the login page , you are not logged in
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Fri Mar 02, 2018 6:15 pm

I tried to login then going to the page you mentioned, it gives an error message: You can't access

No I didn't change anything in the default settings in the config.php file.

I also tried to change the password through the link provided in the login page and it worked, but still doesn't login successfully.

Since Apache 3 is being deprecated, we are at version 4. Latest version of PHP and MySQL.

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Sun Mar 04, 2018 6:17 am

Apache 3 will eventually be deprecated in the short term. If this system is reliant on it then all users of the system will suffer when they move to Apache 4. I think this needs to be investigated. For example, Tomcat is no longer supported in Apache 4, are you using it? What else?

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Wed Mar 07, 2018 7:35 pm

Any ideas what could be the issue?

Can it be related to Apache version or something else?

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Wed Mar 07, 2018 7:53 pm

Can you please tell me where is the log file of the system located?

tempuser
FormaLms Expert
Posts: 85
Joined: Wed Feb 28, 2018 8:26 am

Re: Problem in login after installation

Post by tempuser » Thu Mar 08, 2018 7:43 pm

Is there anybody investigating this issue? Had anybody had it on Apache 4?

Can you tell me what specific PHP configuration you require on the server, because some features may not be enabled.

Thank you.

Post Reply