Vimeo fullscreen not working*

Please report here problems and bugs
Post Reply
nfoster971
Newbie
Posts: 8
Joined: Thu Jun 02, 2016 12:05 am

Vimeo fullscreen not working*

Post by nfoster971 » Sat Jul 02, 2016 7:25 am

I began with a clean install of Forma LMS 1.4.2. I have installed and am building my course.

Problem: Using the HTML Learning Object, I added media with the required url of the Vimeo video. The video is automatically populated with this information when it autodetects the url to be pointing to the iframe:

Code: Select all

<iframe src="https://player.vimeo.com/video/123456789" width="640" height="360" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>. However, all of the "allowfullscreens" are (I am guessing) purified? and removed. 
Problem involves: Firefox 47, Chrome (51.0.2704.104.106), Edge ... all up to date.
Problem *caveat: Works on iPhone safari and Explorer 11 (the iphone may be a fluke, just because it has slightly different programming)

User avatar
max
FormaLms Guru
Posts: 1749
Joined: Thu Mar 01, 2012 10:41 am

Re: Vimeo fullscreen not working*

Post by max » Sat Jul 02, 2016 9:25 am

Hi,
yes, I also think that it's because the html editor purifies the "allowfullscreen". You might want to embed your video into a scorm object, if full screen is important for you.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

nfoster971
Newbie
Posts: 8
Joined: Thu Jun 02, 2016 12:05 am

Re: Vimeo fullscreen not working*

Post by nfoster971 » Sat Jul 02, 2016 10:12 pm

I tried Xerte with both embed and video insert. Still get the same problem.

Is there a way to alter the purifier library so that it doesn't do this?

nfoster971
Newbie
Posts: 8
Joined: Thu Jun 02, 2016 12:05 am

Re: Vimeo fullscreen not working* Updated

Post by nfoster971 » Sun Jul 03, 2016 9:15 am

I have been at this literally all day trying this and that, researching this and that. The internet has some pretty complicated fixes for the purifier and such. Vimeo's comment box on the issue basically said the issue resides in the parent and child iframes needing to include the allowFullScreens and that has to be rectified by the CMS (or in this case, LMS) developers.

Finally, here at 3am on a holiday weekend, I found a solution that seems to work across all the browsers I have previously mentioned. Instead of using all those toolkits, just use one: allowfullscreen="true"

Code: Select all

<iframe src="https://player.vimeo.com/video/123456789" width="640" height="360" frameborder="0"  allowfullscreen="true"></iframe> 
I haven't yet tried it on the scorm creator. I am just happy I got something to work...for now anyways.

User avatar
max
FormaLms Guru
Posts: 1749
Joined: Thu Mar 01, 2012 10:41 am

Re: Vimeo fullscreen not working*

Post by max » Sun Jul 03, 2016 11:02 am

Thank you for posting the - very simple - solution
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
http://www.elearnit.net
http://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
http://elearnit.wordpress.com
Skype: m_ferrari_it

nfoster971
Newbie
Posts: 8
Joined: Thu Jun 02, 2016 12:05 am

Re: Vimeo fullscreen not working*

Post by nfoster971 » Mon Jul 04, 2016 2:06 am

I swear to the heavens it worked last night. I got to messing around and seeing if I could do it also in scorms. Then deleted the one file I got to work last night, and haven't been able to make it work again since, in the scorm or just using the html.

I am just going to embed into a scorm at width="1080" and do that. If someone does need it bigger, I can then instruct them on how to right click and display in new window, which appears to break the object from the bounding parent frame that is being constrictive. It is not an ideal situation, but will work until a cohesive fix occurs.

Post Reply