LDAP not working!

Please report here problems and bugs
Post Reply
User avatar
murat
FormaLms Expert
Posts: 100
Joined: Fri Oct 12, 2012 6:28 pm
Version: forma.lms 1.4

LDAP not working!

Post by murat » Tue Sep 22, 2015 2:49 pm

Hi,
I setting my formalms for ldap but ldap is not working with formalms.
I tried to login into the lms after Formalms login page was white page .

page error message:
Strict Standards: Non-static method UserManagerRenderer::getLoginInfo() should not be called statically, assuming $this from incompatible context in /lib/lib.usermanager.php on line 200

Help me about this issue , please!

User avatar
canelli
FormaLms Guru
Posts: 430
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: LDAP not working!

Post by canelli » Sat Sep 26, 2015 9:54 am

what version of forma.lms ? php ?
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

User avatar
murat
FormaLms Expert
Posts: 100
Joined: Fri Oct 12, 2012 6:28 pm
Version: forma.lms 1.4

Re: LDAP not working!

Post by murat » Sun Sep 27, 2015 12:52 am

hi,
I solved this problem.
Problem : I forgot to install ldap extantion in debianOs
Solve:

Code: Select all

[b]Install php5-lda:[/b]
apt-get install php5-ldap
[b]Reboot apache[/b]
/etc/init.d/apache2 restart
Note: System is Formalms 1.4.1 / PHP 5.4
Last edited by murat on Sun Nov 15, 2015 2:21 pm, edited 1 time in total.

User avatar
canelli
FormaLms Guru
Posts: 430
Joined: Thu Nov 08, 2012 12:21 pm
Version: forma.lms 2.0
Contact:

Re: LDAP not working!

Post by canelli » Mon Sep 28, 2015 8:30 am

Hi murat
good news solving LDAP connection problems.
Formalms users can't enter the system.Only ldap users is login in system.
this is the standard behavior of forma.lms : when LDAP enabled only LDAP authentication occurs.

you must tweak the authentication module to skip LDAP authentication for administrator users.
Cercate nel forum le riposte prima di chiedere. Check the forum before posting
---------------
Claudio Anelli
Joint Technologies - Sistemi avanzati per l'information technology

http://www.joint-tech.com
---------------

User avatar
murat
FormaLms Expert
Posts: 100
Joined: Fri Oct 12, 2012 6:28 pm
Version: forma.lms 1.4

Re: LDAP not working!

Post by murat » Sun Nov 15, 2015 2:31 pm

Hi,
Did you do LDAP settings?
I could not do the LDAP synchronization.
Can you help me?
Because , LDAP users can not access into Formalms system.
(example ldap information: http://www.forumsys.com/tutorials/integ ... st-server/)

Can you tell us step by step?
How do I do LDAP synchronization?

Post Reply